Bladder Infection-pg114532941318

4 Replies
Chantel - April 17

Has anyone gotten a bladder infection while pregnant? i think i might have one. i get sharp pains in my lower abdomen(sp). and it burns AFTER i pee, not during. i'm 37 weeks and ready to have this baby.

 

charliegirl - May 25

Yep - i had one at 10 weeks and didn't want to take antibiotics but the pain was too bad to ignore. After I'd taken the antibiotics the pain went away in about a day and I wished I'd taken them sooner. The doctor told me it was safer to take the medication than to leave the infection. I've also heard it's not good to have an infection when you go into labour so I'd go and get tested if I were you. Good luck :)

 

kikistone - May 26

Me too...mine was at 14 weeks and I had to have surgery so it had to be cleared up. I took antibiotics and I am now 24 weeks...no sign of problems!

 

starr - May 28

Yep I also had a bladder infection about 2 months ago but I didn't notice any symptoms.I found out after a urine test.They just put me on antibiotics for 7 days and it cleared up. I am now 37wks and no problems since.

 

Linda99 - June 6

Just started with one on Sunday. God they are miserable! I'm 18 weeks. I get these about twice a year so I knew right away and I had also read that it's important to treat it so I called the ob right away. 3 dyas on antbiotics and I'm still having some discomfort. Chantel, I hope you followed up with your dr.

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?  
Start A New Discussion