Someone Please Help Me PLEASE

4 Replies
rachel s - May 2

I am 9 days late for my period. I took a prego test today and got a negative. I was just wondering if anyone had ever taken a pregnancy test and got a negative, then a little while later, from a blood test or urine test, they had gotten a positive? I also experienced what I beleive was implantation bleeding 7 - 9 DPO. It started out light pink and only happen when I wiped while using the restroom and hadn't lasted any longer then a day. The pink spotting was never enough to wear a daypad/pantie liner. The next day, I had gotten light brown spotting. Still only happend when I wiped and only a couple of times it got on my undies. The VERY VERY light brown lasted 2 days, but was still never enough to wear day pad. Since the, I have had nothing besides a LOT of extra white CM (discharge). Loads more then I would receive and prolonged too! anyone thats pregnant.... can you please help me.

 

Saird - May 2

Hi, I had this too- like a pinkish tinged CM and also some brown spotting on a different day, only when wiping. I haven't tested yet. I'm on CD40.

 

rachel s - May 2

what does CD40 mean? Do you know how many DPO you were? And when you get your period next?

 

Saird - May 2

It means cycle day 40- I have no idea when I O- my cycle is erratic- it's usually between 38-40 days though. I would have thought I'd get my period now- or NOT.

 

18wbabynov - May 2

im prego, and i waited a lot longer than most to get the test... i just had them do a blood test though. my best friend got a false negative, and then went with me to get the blood test, and we are now both positive! i would just go get tested by a dr. free at a clinic or with your normal health care provider...

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?  
Start A New Discussion