Any One Get A Yeast Infection Bladder Infection While TTC

4 Replies
Jen - April 21

I don't know what is wrong, but I felt like I had a yeast infection, then took some monastat, now feel like I have a slight bladder infection. Haven't had s_x since saturday and my period was last week, but I have small cramps and just feel run down. Any one have any ideas?

 

Grandpa Viv - April 21

Progesterone changes the chemistry of the v____a and the urethra. The balance of natural microorganisms can change. Fatigue and small cramps can be early signs. No tummy upsets?If your period last week was unusual in any way, a home preg test Saturday morning first pee would be a good idea. Good luck!

 

Jen - April 21

Thank you for the response. My stomach has been on and off...I have the chills but last monday I took a preg test and it was negative. My period only lasted about a day very light, then spotted for a couple of days. I have been taking my temps early morning though and they are down. Any further thoughts?

 

Jena - April 21

when we were TTC I had a month-long yeast infection. It was horrible. I think my body wasn't used to having s_x as much as we did! it just wouldn't go away until I got a prescription pill - forget what it is called but you can't take it if you are preggo.... GL!

 

Jess - April 21

I'm going through the same thing right now. me and my bf just went through a miscarriage a couple of months ago, and this month we had a lot of s_x and i started spotting for a couple of days, i only noticed it when i went to the bathroom. now it feels like i have a bladder infection. dose anyone have an answer? and jen, i wiss you good luck!!

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?