So Confused

2 Replies
ashleyd - June 8

Ok, I know I've posted a lot about this month, but it's been weird. Back info: Last month my AF (which is clockwork) was 2 days late...no biggie...it was certainly normal, if not heavy. This cycle, I got ewcm near CD12 (which was accompanied by slight cramping...) which was really early for me...and my discharge is fairly predictable, so I assumed it was O'd. However, I should have not O'd until like the 3-4th of this month. Now I'm on CD22 w/ extreme fatigue, slightly tender bbs, and a watery whitish clear discharge (no odd smell...nothing "weird" that would make me think I have an infection). By my calculations I'd be about 9dpo, but by what I should be, I'd be like...5po. Is it possible I had the ewcm for about 5 days? and then it stopped? This whole cycle has been so confusing - that I'm not sure when now that I O'd. help :(

 

ashleyd - June 9

Today I'm more crampy, like between my hip bones down to where my bladder is. My b___sts aren't really sore or tender, just my nipples...and even after another 11 hours of sleep, I'm still exhausted. Today my discharge is still watery...but when going to check farther in - I get like a jelly string like glob every now and then that comes out. I've had that before, but never this late in my cycle (and never in amounts this large). The globs don't seem to make it very far down, and they are clear... This is so bad...lol, I don't know what's going on :(

 

ashleyd - June 9

oh...and this puts me on CD23, 6dpo according to my calnedar...and 10dpo according to when I felt I was ovulating. LMP was May18th, cycles are about 32 days long. No sharp pains on either side, just a generalized pain in the middle...much like AF and I feel really hot.

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?