More Heartbreak Can You Help

2 Replies
Longing for a baby - February 26

Hi After first round of Clomid It was found that I didn't ovulate, on day 21 progesterone level came back 6 :-( Started Clomid 100mg day 2-6.....went for first follicle scan yesterday (cd9) and had no lead follicles- going back Friday....but I presume this cycle isn't going to work...... And if this is the case.....thats 2 rounds and no luck, Is it ever going to work, anyone been in my situation? Please help xx

 

Teddyfinch - February 27

yeah that would be me. i've been through 3 rounds and i only have weenie follicles. clomid just doesn't work for some people.

 

angelgabby84 - February 29

Hi! I took clomid 2-6 100mg and it was thought in the beginning that it didnt work for me also. However with patience and perseverance, we discovered that my follicles didn’t mature until late in my cycle (really late about CD20) and then I wouldn’t O till even later (around CD28 I think). I eventually gave up completely after about 10 months (not 10 cycles because they were so long) and became PG my first cycle and I am now 23weeks and 1day pregnant with a boy. Wahoo………….. I think it all came down to stress with me and after relaxing and not thinking about it it happened. Good luck to everyone who is TTC and here is some ~~~Baby Dust~~~

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?