GRANDPA VIV I Need Your Help Thank You

3 Replies
Meg - April 27

Today I woke up this morning and when I wiped, there was blood. I was supposed to get my period the 16th this month. But no sign of blood has shown except for this morning. I have had all the symptoms of pregnancy, but now this! My last "period" if that is what is was (cuz it lasted only 3-4 days on and off and usually it is 7 days) was on March 19. (ended on 23rd) My boyfriend and I had unprotected s_x on March 9 and 10. Was that "period" implantation bleeding or an abnormal AF? On April 1 and 2 we also had unprotected s_x. Could this be IB from that time? We also have had unprotected s_x on April 6, 14, 23, 24, and 25. This "AF" now doesn't seem normal because there's only a little on the pad. (and when I wipe, but it's not normal) Sorry this is so much! Also, on April 4, I took a hpt (Clearblue digital) and it was neg. April 25, I took another one and it was neg. Are these tests really to be trusted? And is this IB or is this my dreaded AF? Thanks!!

 

bump - April 28

bump

 

Grandpa Viv - April 28

This has been going on long enough that I think I would take a different test (First Response Early Result) and then make a doctor appointment regardless, either a prenatal visit or a diagnositic visit to determine why your body is acting out. You may be pregnant from the March 9th s_x with an IB March 19th and a bum test pack on hand. Good luck!

 

Meg - April 28

Thank you so much Grandpa Viv. Your advice helps so much! I need all the luck I can get, thank you!! :)

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?