PLEASE RESPOND

2 Replies
Caitlyn - May 16

About a month and a half ago I had unprotected s_x. No condom, no pills, no anything but withdrawl. We had s_x probably 8-9 times. Stupid I know but I knew him well. Anyway 8 days later I had cramps like I had to go to bathroom but couldn't. I had very wet discharge. Almost like water. I went to pee and when I wiped there was brown stuff on toilet paper. Then the rest of the day nothing. Then the next day as the pain or cramps continued I wiped and again there was brown stuff on toilet paper. Nothing else the rest of day. Then 10 days later. I took a pregnancy test which was negative. I took this test because I had a bright red/pinkish slimy period. Lasted only 3 days. Still getting negative HPT'S. Did this sound like implantation bleeding(the brown discharge when wiping) and a last period or what? If so, why the negatives? I am stressing.

 

Caitlyn - May 16

Anybody?

 

E - May 17

Hi Caitlyn. I also had s_x and he came inside.It was a day before my period so we didn't think anything could happen. I also had the brown discharge you are describing. I had it for 10 days about. My last real period was March 19. The spotting started April18 and now I'm missing another period for may. I got a negative a week ago so Idon't know what's wrong either. But I guess we could have had implantation bleeding because I'm getting lot of signs: veins, sore bigger b___sts, nausea, runny nose, tired, food aversions, cravings...

 

ADD A COMMENT:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.

Forgot your password?
Need Help?
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?